Crashlytics voor ndk hebben geen toegang tot het systeem

kathy zhou 07/26/2017. 1 answers, 97 views
android-ndk android-ndk native crashlytics google-fabric

Crashlytics voor ndk hebben geen toegang tot systeem unwind with error info: Kan geen bruikbare afwikkelbibliotheken vinden op het apparaat, terugvallen op eenvoudig afwikkelen

Misschien heeft dit falen ertoe geleid dat we maar één regel hebben voor de native crash.

Mijn apparaat is Nexus 6 met platform 7.1.1

1 Answers


Mike Bonnell 07/26/2017.

Mike van Fabric hier. Ja, als we libcorkscrew en libunwind niet kunnen vinden, schakelen we over naar onze eigen eenvoudige unwinder. De eenvoudige unwinder kan alleen het bovenste frame van een crash krijgen, daarom zie je dit gedrag. We zijn van plan dit beter te maken.

4 comments
1 kathy zhou 07/27/2017
Bedankt voor je snelle reactie. Mijn verdere vraag is: is hier een oplossing voor? Kunnen we libunwind toevoegen aan ons project om dit probleem op te lossen?
Mike Bonnell 07/28/2017
Helaas niet op dit moment, maar zoals ik al zei, we werken eraan dit beter te maken.
Maris B. 08/23/2017
@MikeBonnell - elke ETA over "dit beter maken" ?. Een maand later en nog steeds "kon geen bruikbare afwikkelende bibliotheken vinden op het apparaat, terugvallen op eenvoudig afwikkelen" op Android 5.0 en Android 7.0
Mike Bonnell 08/23/2017
Ik heb geen ETA die ik openbaar kan delen. Als u geïnteresseerd bent in het testen van iets waar we misschien aan werken, e-mail dan ondersteuning (at) fabric (dot) io met een verwijzing naar deze thread.

Related questions

Hot questions

Language

Popular Tags